HP作成支援 - 質問など受付掲示板


メニュー


スレッド一覧


投稿記事一覧


親タイトル
[1] 「GIF Animation Maker CGI」サイズ相違のエラー原因
投稿者情報
  • PONTA
  • Mail
  • HP
  • 2004年03月17日(水) 16時01分
投稿内容

いつも「GIF Animation Maker CGI」を御利用になられている皆さんに朗報です。今まで、原因不明なエラーの解決への糸口が見つかりました。原因は画像チェックに用いているJavascriptにあるようです。ブラウザ側の問題でしょうが、取得データの反映が遅れるという事が有るようです。その結果、サイズが不明になり、取得出来たサイズと比べると相違が生まれエラーになるようです。

この「画像サイズが違いますエラー」において、若干の修正なんかを加えてみましたが、まだエラーが出るようでしたら、エラーメッセージを添えてこのスレッドに返信して下さい。今までよりも詳細なエラーメッセージを出すようにしています。

今後とも、WSJ21.NETをGIF Animation Maker CGIを宜しくお願い致します。

記事情報

親タイトル
[2] 画像サイズが違うとでるんです!!
投稿者情報
  • とも
  • .
  • .
  • 2004年03月16日(火) 21時36分
投稿内容

初めましてwいつもいろんなところに使わせて頂いております。この前からなんですが作成しようとしたら「W画像サイズが違います」とでてくるんですが。。。どうしたらよいのでしょう?サイズは全く同じなんです。よく分からないのでお返事いただけると嬉しいです。

記事情報
子タイトル
Re: 画像サイズが違うとでるんです!!
投稿者情報
  • PONTA
  • Mail
  • HP
  • 2004年03月17日(水) 15時50分
投稿内容

どもさん、始めまして。修正してみましたが、まだエラーメッセージが出る場合は、エラーメッセージを添えてお願い致します。

記事情報

親タイトル
[3] GIFアニメ作成させていただきました
投稿者情報
  • あいす
  • .
  • .
  • 2004年03月14日(日) 16時10分
投稿内容

メールでアップしたサイトURL(ブログですが)はご報告させていただきました。ご確認くださいませ。とても便利で助かりました。ブログ記事でもご紹介させていただきました。また利用させていただきたいと思います。

記事情報
子タイトル
Re: GIFアニメ作成させていただきました
投稿者情報
  • PONTA
  • Mail
  • HP
  • 2004年03月14日(日) 17時16分
投稿内容

どうもあいすさん、御報告ありがとうございます。確認させて頂きました。GIFアニメ作成CGIはドンドン使って広めて下さいね♪

HPとか掲示板に貼り付けて下されば良かったのに(自分が楽したいから(笑)。著作権問題とかレンタルブログも大変なんですね。これからもブログ運営、頑張って下さいね。

記事情報

親タイトル
[4] パーミッションもついて
投稿者情報
  • トルマリン
  • .
  • .
  • 2004年03月06日(土) 17時52分
投稿内容

パーミッションを701にしてアクセスすると707に変えてくださいと表示されましたので
707に変えたところ500エラーでてしまいどうにもこうにもです・・・。700や777
に変えたりもしたのですが改善できず・・。どうかお助けください;;

記事情報
子タイトル
困りましたね
投稿者情報
  • k
  • .
  • .
  • 2004年03月06日(土) 18時17分
投稿内容

705ではどうでしょう?
アドバイスできるかわかりませんけど、設置するサーバーはどこですか?
あとソースに手を加えた箇所とかその他できるだけ詳しく書いてもらえると何かアドバイスできるかもです。

記事情報
子タイトル
Re: 困りましたね
投稿者情報
  • トルマリン
  • .
  • .
  • 2004年03月10日(水) 01時56分
投稿内容

返信送れてすみません。705で試してみましたが相変わらず「707に」と表示されます;;
tok2を使ってるのでもしかするとと思いTok2cgi.pmを使って見るもウマくいかず・・・。
ソースはまだいじってはおりませぬ・・。

記事情報
子タイトル
tok2特殊だ
投稿者情報
  • PONTA
  • Mail
  • HP
  • 2004年03月10日(水) 18時32分
投稿内容

tok2サーバでテストしてみました。実際パス[/home/www/html/home2/kokyo/ecobbs/]と仮想パス[/home/member2/kokyo/ecobbs]が食い違ってますね。そりゃ無理だわ(汗)。ということで、パスが認識されない場合は、パーミッションチェックを行わないように改良しました。DLし直して下さい。バージョンはv1.14のままですが中身はv1.14aです。

記事情報
子タイトル
ありがとうございます!!
投稿者情報
  • トルマリン
  • .
  • .
  • 2004年03月10日(水) 21時46分
投稿内容

おかげさまでウマいこといきました!!自分では一体何が悪くてこうなったのか原因すら理解できていない状態ですが、恐らく大変なのだろうバージョンアップをしていただいてホントにありがとうございます!大事に使わせていただきますです^^

記事情報
子タイトル
何気にバグまで修正
投稿者情報
  • PONTA
  • Mail
  • HP
  • 2004年03月10日(水) 22時21分
投稿内容

いえいえ〜♪不具合が分かっただけでもこちらにメリットはありました。更に別な方法に切り替えました。あと、画面切替デフォルト「Location」を「Refreshタグ」に変更しました。tok2ならCookie保存のために「Refreshタグ」に変更して下さいって強制的になるように設定してた(笑)。ポップアップtok2ならlocationでもいけた気がする。

P.S.:管理人が記事編集する時にユーザメアドが上書きされる問題を解消。気付かなかった(汗)。今日は1.14,1.14a,1.14bと何気に上げすぎ(笑)。あと、そろそろ忙しくなるので、更新が出来ないかも知れませんね〜♪出向先が決まれば恐らくサポートできないくらい忙しいッぽい旨を伝えておきます。<ここで伝えられてもね☆

記事情報
子タイトル
バージョンアップ!?( ̄□ ̄;)
投稿者情報
  • k
  • .
  • .
  • 2004年03月13日(土) 19時21分
投稿内容

バージョンアップ版早速ダウンロードさせていただき、差し替えさせていただきますた。
特に不具合もなく安定して動作しているようです。

PS
失礼かと存じますが、先日お問い合わせ?のありました私のサイトのURLをメールで送付させていただきました。
一応リンクを貼らせていただいた証拠ということで(汗
出向先が決まり、多忙のようですが、これからも健康に留意して頑張って下さいね。

記事情報
子タイトル
無問題
投稿者情報
  • PONTA
  • Mail
  • HP
  • 2004年03月14日(日) 14時17分
投稿内容

問題が無く動いて良かったです〜♪メール確認しました。リンクどうもです〜♪素晴らしき紹介文「SEOにも力を入れており」というのが特に(^-^;)。これからも程良く頑張りたいと思いますので、これからもお互いヨロシクです☆

記事情報

親タイトル
[5] GIFアニメ
投稿者情報
  • よっちゃん
  • .
  • .
  • 2004年03月13日(土) 10時21分
投稿内容

GIFアニメ使わせて頂きました。とても簡単にできて、動いた時にはとても嬉しかったです。只今HP作成中ですので、アップしましたらリンクを貼らせていただきます。ありがとうございました。

記事情報
子タイトル
どもです
投稿者情報
  • PONTA
  • Mail
  • HP
  • 2004年03月14日(日) 14時12分
投稿内容

でもよっちゃん、これからもヨロシクです〜

記事情報

親タイトル
[6] ecoupBBSの複数設置
投稿者情報
  • dxsmopuiM
  • .
  • .
  • 2004年03月11日(木) 10時57分
投稿内容

ecoup掲示板を同じサーバに3つ置きたいのですが、可能ですか?
その場合、
public_html/cgi-bin/1/ecobbs.cgi
public_html/cgi-bin/2/ecobbs.cgi
public_html/cgi-bin/3/ecobbs.cgi
等、フォルダの名前を変えてやればよろしいですか?

記事情報
子タイトル
複数設置は可能です
投稿者情報
  • PONTA
  • Mail
  • HP
  • 2004年03月11日(木) 17時36分
投稿内容

それで大丈夫です。

追伸:質問は、実際テスト設置してからお願い致します。強いて必要のない質問及び回答を避ける為にです。注意書きに書き加えるので、以後お願い致します。

記事情報

親タイトル
[7] ECOUP掲示板画像ファイル保存場所
投稿者情報
  • xnuil
  • .
  • .
  • 2004年03月10日(水) 12時51分
投稿内容

ECOUP掲示板の設置の件ですが、UPロードされた画像が大量になると予想される場合、画像ファイルだけ他のサーバへ自動で送る(飛ばす)ことはできるのでしょうか?imgfだけ他のサーバに置き、ecobbs.cgiの内容を絶対パスでそのサーバに指定すればできますか?できましたら改変箇所も教えてください。

記事情報
子タイトル
Re: ECOUP掲示板画像ファイル保存場所
投稿者情報
  • PONTA
  • Mail
  • HP
  • 2004年03月10日(水) 18時38分
投稿内容

結論から言いますと無理です。サーバ間のsocket通信しなくちゃいけなく、またサーバに高付加が掛かるため、そこまで対応する気はありません。

つきましては、大容量サーバで使用して下さい。最大転送量の問題もありますので、自サーバが望ましいかと思います。それか、記事数を制限するかです。

記事情報

親タイトル
[8] 対策願い/クッキーの文字化け、その他
投稿者情報
  • k
  • .
  • .
  • 2004年03月05日(金) 14時24分
投稿内容

またまた新たな問題が出てきましたのでご相談させて下さいf^^
今頃になって発覚したのですが、クッキーの文字化けによって投稿フォームの「おなまえ」欄のテキストエリアが表示されずに、「削除キー」が「おなまえ」欄の位置まで寄って、尚且つ「削除キー」欄の中に文字化けした「おなまえ」を含むHTMLソースが表示される状態になります。

おなまえ|[^藏? /> 削除パス <input type](必須)

投稿フォームの吐き出されたソースはこんな感じになります。
<tr><td class="frml">Name</td><td class="frmc"><input type="text" size="32" maxlength="20" name="name" tabindex="2" accesskey="v" value="^藏・ />
削除パス <input type="password" size="9" maxlength="13" name="pass" class="pass" tabindex="3" accesskey="k" value="xxxxxxxx" /> <small class="red">(必須)</small></td>

見ていただければわかるように、「value=」の「"」が括られない状態となってHTMLソースが正しく認識されないようです。
ecobbs.cgiの当該ソースを見ると、「value=\"$c_name\"$empty>」となっており、「おなまえ」に該当するクッキーである「$c_name」の値が文字化けしていることになります。
そこでGoogleで「クッキー 文字化け」で検索したところ以下のようなソースを見つけました。
http://www.futomi.com/lecture/cookie/
これによるとクッキーは「URLエンコードをしてからセットしなければいけません。」とあるのですが、ecobbs.cgiのクッキー発行とおぼしき箇所を見たかぎりそれに該当するような記述がありませんでした。
実際は他に原因があるのかもしれませんが、何か対策できる方法があればご教授下さい。

尚、文字化けが起こるのは名前に何らかの特定の日本語を使用した場合に起こるようです。
例えば私の環境では「名無し」でクッキーが文字化けして、最初に書いたような状況になってしまいました。
念のため何も書き換えていない配布状態のままのスクリプトを使い、クッキーも一度削除したうえで動作確認しましたが、やはり同じ状況になります。
別のサーバーでも同じ症状が出ました。
ただ不思議なことにこちらで公開されているサンプルをお借りして確認したところ、何故か文字化けがしません(汗
それと私の環境でもIEでだけは文字化けしません。
これは恐らくIEの実装バグがHTMLの不備を見逃して動作してしまっているようです。(IEのHTML解釈のデタラメさは有名ですね)
ちなみに試験にはOperaを使用しています。

記事情報
子タイトル
追伸
投稿者情報
  • k
  • .
  • .
  • 2004年03月05日(金) 14時35分
投稿内容

書き忘れましたが、readme.htmlを拝見したところ「新着情報」を出力するための外部.jsファイルについての記述がありましたが、配布されている圧縮ファイルの中には該当するファイルが含まれていないようです。
念のためv.111のフォルダも確認してみましたが、やはり同胞されていないようです。
これについてはバージョンアップに伴い廃止されただけなのでしょうか?

記事情報
子タイトル
Cookieエンコードやってませんが(汗)
投稿者情報
  • PONTA
  • Mail
  • HP
  • 2004年03月05日(金) 21時03分
投稿内容

今更ながらしわ寄せが・・・。対策を練らなくてはならないですね(汗)。Shift_JISが上手く認識されていないのかな?UTF-8,16で送信されてるかなぁ〜(汗)。再現出来ないので、謎です。今更ながらエンコードしてみるかな(^-^;♪ECOUP2の配布がドンドン後になってくる(汗)。バグが無くなるから良いか〜♪あっ、全CGIが対象だ・・・(鬱)

>新着情報
廃止されました。更新履歴しか書き換えてないのがバレた(汗)。v1.13では、新たな方法で最新アップ画像だけが採用されていますが、商用向けの改造なので、まだ未公開です。

記事情報
子タイトル
文字化け対策:暫定措置
投稿者情報
  • PONTA
  • Mail
  • HP
  • 2004年03月05日(金) 21時31分
投稿内容

ソースはAmazonRankingの方から調達してきました(笑)。次の様に変更して下さい。対象「ReLoad」「get_cookie」関数。分かると思うので、該当部分のみ記述。仮想配列毎にしようぜ(謎)

my $c_data = "$in{'pass'}$in{'name'}$in{'mail'}$in{'url'}$in{'clr'}$in{'trip'}";
$c_data =~ s/(\W)/'%'.unpack("H2", $1)/ego; $c_data =~ s///g;
print "Set-Cookie: eco_bbs=$c_data; expires=Thu, 1-Jan-2030 00:00:00 GMT\n";
$tok2 = "<meta http-equiv=\"Set-Cookie\" content=\"eco_bbs=$c_data; expires=Thu, 1-Jan-2030 00:00:00 GMT;\"$empty>";

my($k, $v) = split(/=/);
$k =~ s/^ //g;
$v =~ s/%([a-f\d]{2})/pack("H2", $1)/egi;

記事情報
子タイトル
文字化けこそ解消しましたがまだ問題があるようです。
投稿者情報
  • k
  • .
  • .
  • 2004年03月06日(土) 09時27分
投稿内容

アドバイスいただいた方法でエンコード&デコードをしたので文字化けこそなくなり、レイアウトが崩れるバグは無くなりましたが、クッキーの値が正常に取り込めないようです…
自分でもGoogleで検索しながらいろいろ修正を加えたりしてみましたがどうにもお手上げです…
症状としては$in{'pass'}〜${'trip'}までの値がデコードされたあとに$c_clr以外は全て$c_passに集約されてしまって、削除キーの入力フォームに$c_pass以外の値も含まれてしまいます。
当然$c_name、$c_mail、$c_urlなどの値もnullになります。
どうかお助け下さいm(_ _)m

記事情報
子タイトル
コードが化けてる(汗)
投稿者情報
  • PONTA
  • Mail
  • HP
  • 2004年03月06日(土) 14時40分
投稿内容

区切り文字として使用している半角の「<>」が削除されていました。掲示板の仕様なんですよ(苦)。というわけで、ReLoad関数のを半角で「$c_data =~ s/<>//g;」としてやって下さい。

記事情報
子タイトル
自己解決できました!
投稿者情報
  • k
  • .
  • .
  • 2004年03月06日(土) 16時47分
投稿内容

お手数かけまして申し訳ないです・・・
お返事いただいた""の区切り追加は当然ながら気が付いて追加していました(汗
""を追加しても削除キーが"xxxx"となるだけで、基本的には変わらずでした。
Googleで検索しながらいろいろな例を参考にみようみ真似でどうにか以下のコードを記述して正常な動作を得ることができましたf^^
初心者のくせに勝手にあれこれ手を加えてしまってすみません。

#### リロード処理 - ReLoad (Cookie:1=ON,0=OFF)
sub ReLoad {
my $fg_cookie = shift; #配列の最初の要素を取り出す。取り出された要素は配列から削除される。
if ($fg_cookie && !$in{'nocookie'}) {
@c_tmp = ("$in{'pass'}","$in{'name'}","$in{'mail'}","$in{'url'}","$in{'clr'}","$in{'trip'}"); #テンポラリ配列に格納
$c_data = join "", @c_tmp; #区切りコード""付加

$c_enc = $c_data; #動作確認用

$c_data =~ s/([^\w ])/'%' . unpack('H2', $1)/eg; #URLエンコード
$c_data =~ tr/ / /;

print "Set-Cookie: eco_bbs=my $c_data; expires=Thu, 1-Jan-2030 00:00:00 GMT\n";

$tok2 = "<meta http-equiv=\"Set-Cookie\" content=\"eco_bbs=$c_data; expires=Thu, 1-Jan-2030 00:00:00 GMT;\"$empty>";
}

sub get_cookie {
$env_tmp = $ENV{'HTTP_COOKIE'}; #クッキー取得
($k, $v) = split(/;/, $env_tmp); #クッキー名称・内容とクッキーナンバーに分割
($k1, $k2) = split(/=/, $k); #クッキー名称と内容を分割

$k2 =~ s/^ //g;
$k2 =~ s/%([a-f\d]{2})/pack("H2", $1)/egi; #クッキー内容をURLデコード

$kk = $k1; #動作確認用
$vv = $k2; #動作確認用
$hc = $ENV{'HTTP_COOKIE'}; #動作確認用

@k_tmp = split(//, $k2); #区切りコード""を基準に配列変数に代入
$c_pass = @k_tmp[0]; #以下、配列変数から各フォーム用変数に代入
$c_name = @k_tmp[1]; #同上
$c_mail = @k_tmp[2]; #同上
$c_url = @k_tmp[3]; #同上
$c_clr = @k_tmp[4]; #同上
$c_trip = @k_tmp[5]; #同上

とりあえず動作は正常になったわけですが、デコード部分の「#以下、配列変数から各フォーム用変数に代入」の箇所がどうにもすっきりしない記述かと思われます。
ここをすっきり記述するにはどうすればよいでしょうか?

記事情報
子タイトル
<>問題が。。。
投稿者情報
  • PONTA
  • Mail
  • HP
  • 2004年03月06日(土) 17時05分
投稿内容

my $c_data = "$in{'pass'}$in{'name'}$in{'mail'}$in{'url'}$in{'clr'}$in{'trip'}";」の所も「<>」が削除されていた見たいですね(汗)。

>Google参照コード
join関数使うんだったら配列使っても良いかなぁ☆でも、かなり無駄が多い気がするのは気のせいだろうか・・・?取り敢えず、分解したものを各変数に直接代入。「($c_pass, $c_name, $c_mail, $c_url, $c_clr, $c_trip) = split(//, $k2);」配列を使わない分メモリ節約になるかな♪

というわけで、頑張れ〜♪

記事情報
子タイトル
うぁ!文字化けしてる?
投稿者情報
  • k
  • .
  • .
  • 2004年03月06日(土) 17時06分
投稿内容

"<>"がところどころ抜けて表示されてしまうようなので、借り物のアップローダーにソースを貼っておきました。
ttp://uploader.org/normal/data/up2577.txt

記事情報
子タイトル
ムカついてきたのでエンジンソース変更
投稿者情報
  • PONTA
  • Mail
  • HP
  • 2004年03月06日(土) 17時11分
投稿内容

「<>」が表示出来るようになりましたとさ☆でも、ドッカでバグが混入してたり(^-^;)

記事情報
子タイトル
Re: ムカついてきたのでエンジンソース変更
投稿者情報
  • k
  • .
  • .
  • 2004年03月06日(土) 17時19分
投稿内容

入れ違いになりましたf^^

@c_tmp、$c_dataの配列の部分は元の"$in{'pass'}<>$in{'name'}〜略〜$in{'trip'}";記述だと何故か$c_dataには$c_passにしか値が入らないのです(疑問だ・・・

あと同様にデコードの方も直にsplit関数では@k_tmpに値が入らなかったので一旦配列に置き換えました(これも謎・・・

記事情報
子タイトル
ちょっと早とちりしました(汗
投稿者情報
  • k
  • .
  • .
  • 2004年03月06日(土) 17時28分
投稿内容

>あと同様にデコードの方も直にsplit関数では@k_tmpに値が入らなかったので一旦配列に置き換えました(これも謎・・・

これは上手くいきました!ちょっとソースがすっきりしてよい感じになりました。
ありがとうございます。

($c_pass, $c_name, $c_mail, $c_url, $c_clr, $c_trip) = split(/<>/, $k2);

でOKでした。

記事情報
子タイトル
早っ!!!
投稿者情報
  • k
  • .
  • .
  • 2004年03月06日(土) 17時37分
投稿内容

<>がちゃんと表示されるようになってますねf^^
すばやい・・・

記事情報
子タイトル
半リアルチャットか!?
投稿者情報
  • PONTA
  • Mail
  • HP
  • 2004年03月06日(土) 17時48分
投稿内容

会社からの連絡が来て、しょんぼり(T_T)。

取り敢えずは、でけたでけた。まぁー謎の部分はひたすらに謎ですが・・・。

記事情報
子タイトル
クッキーについて新たな不具合が(汗
投稿者情報
  • k
  • .
  • .
  • 2004年03月07日(日) 16時28分
投稿内容

昨日はありがとうございました。
早速ですが昨日き解決したかのように思えたクッキーの文字化け対策で新たな不具合が出てきました(汗
その不具合というのは「投票」を行うと新たなクッキー「eco_vote=value」が発行されるわけですが、クッキーを読み込む際にブラウザによって投稿に関する名前・削除キーなどのクッキーと、クッキーの有無チェック用フラグのクッキー・投票用のクッキーなどの読み込み順番がブラウザによって相違するようで、支障が出てきました。

$ENV{'HTTP_COOKIE'};
で読み込んだ生の状態のクッキー例
【IE】
クッキーの値:eco_cook=1; eco_bbs=7653<>名無しローソン<><><>000099<>9712; eco_vote0002=3

【Opera】
クッキーの値:eco_bbs=0001<>名無しさん<><><>993300<>; eco_vote0001=1; eco_vote0003=1; eco_vote0008=1;

という感じです。
どちらのブラウザでも一旦クッキーを削除して確認しましたが、読み込まれる順番は各ブラウザで固定のようです。
ただ見てもらえばわかるように順番がそれぞれのブラウザで違うために投稿フォームでのクッキーの反映がおかしくなり、IEでは正しく機能しないといった状態になります。
他のブラウザ、Macなどではどうなるのかまではわかりませんが、配列を使ってクッキーネームを識別するなどしないといけない予感です…
具体的にどうすれば解決できるか理屈はわかるのですが、今はそこまでの技量がないので、ちょっと時間をかけて勉強しながら判定ルーチンを作成するしかないようですf^^
お時間があれば助けていただきたいのですが(汗
それは無理でも昨日の対策では不具合があるという報告もかねて質問させていただいた次第です。
ブラウザごとのクッキーの認識の違いについてはよそで調べてみますので、何かわかりましたらまた書き込みさせていただきます。

記事情報
子タイトル
仮想配列にバグ発覚!?
投稿者情報
  • PONTA
  • Mail
  • HP
  • 2004年03月07日(日) 17時37分
投稿内容

配列じゃなくて、仮想配列使ってます(^-^;)。get_cookie関数の「$c_vote{'$1'} = $v if ($k =~ /^eco_vote(\d )$/);」を「$c_vote{"$1"} = $v if ($k =~ /^eco_vote(\d )$/);」に変更してください。シングルかダブるかの違い・・・仮想配列「c_vote」をトレースしたら理由が分かりますね。(プログラムソースなので引用+code要素を用いてみた編)

# 仮想配列内を表示してみる罠
foreach ( my($k, $v) = each(%c_vote) ) {
print "記事番号[$k] = 投票値[$v]";
}

追伸:ココはバグ報告兼Perl勉強会みたいになってるね☆

記事情報
子タイトル
なんとなく自己解決f^^
投稿者情報
  • k
  • .
  • .
  • 2004年03月07日(日) 17時56分
投稿内容

改造前のソースをよくよく眺めていて、foreach{}で回していることに気づき、
解決方法がわかりました。
あとは自分で何とかやってみます。
どうしてもわからなければまたご相談します。

記事情報
子タイトル
たびたびすみません(>_<)
投稿者情報
  • k
  • .
  • .
  • 2004年03月07日(日) 18時01分
投稿内容

レスしていただいたのを見逃していました(汗
配列と仮想配列…違いがいまだによくわかっていなかったり(お
精進しますf^^
アドバイスいただいたことを踏み台に試してみますね。
あ、それからチャット状態にしてしてしまってホント申し訳ありません。
ですが勉強会?は大変参考になりますf^^

記事情報
子タイトル
踏み台にされる
投稿者情報
  • PONTA
  • Mail
  • HP
  • 2004年03月07日(日) 23時25分
投稿内容

kさん、かなり改造できてるみたいで(^-^;)。頑張れ頑張れ〜♪これって無意味レス(笑)?

記事情報
子タイトル
出来ました(感動!)
投稿者情報
  • k
  • .
  • .
  • 2004年03月08日(月) 14時25分
投稿内容

sub get_cookie {
foreach ( split(/;/,$ENV{'HTTP_COOKIE'}) ) {
my($k, $v) = split(/=/);
$k =~ s/^ //g;
$v =~ s/%([a-f\d]{2})/pack("H2", $1)/egi;
($c_pass, $c_name, $c_mail, $c_url, $c_clr, $c_trip) = split(/<>/, $v) if ($k eq 'eco_bbs');
$c_vote{"$1"} = $v if ($k =~ /^eco_vote(\d )$/);
$c_cook = $v if ($k eq 'eco_cook');
$c_himg = $v if ($k eq 'eco_himg');
} $c_clr = "666666" if (!$c_clr);
}

でうまくいきましたf^^
やっぱり元がうまく出来てるのに勝手にイジってはマズかった(汗

>踏み台にされる
言葉が不適切で申し訳ありませんf^^
まだまだ未熟ですが頑張って勉強します。

それと先日の環境によっては文字化けしない件ですが・・・
http://216.239.57.104/search?q=cache:mcfRyrnVqroJ:www23.tok2.com/home/FAQ/cgi1.html 繧ッ繝・く繝シ縲荳榊・蜷・amp;hl=ja&ie=UTF-8
にあるようにHTTPヘッダーの問題があるのかもしれないですね。
一応設置するサーバーはTOK2ではないのですが、無料レンタルサーバーなので当然自動挿入広告があるもので、それもひとつの要因だったのかもしれません。
aaacafe!でも試しましたが、やはり同様な症状がでました。
ただ、広告の無いレンタルサーバーでも同様な症状になったことはまたまた疑問なのですが・・・

記事情報
子タイトル
トクトクかぁ〜
投稿者情報
  • PONTA
  • Mail
  • HP
  • 2004年03月08日(月) 16時40分
投稿内容

何気にtok2対策してたりするんだよね(^-^;)。で、最近分かったこと。サーバの設定に依存する。サンプリングした無料サーバ、「infoseek, tukaeru, prohosting」は正常、「tok2, aaacafe, xrea, aqweb」で不具合が起きます。但しxreaで広告免除サービスが適応された場合(当サイト)は正常です。これらの適切な回避方法が何となく分かりましたので、今後対策を検討してみたいと思います。というわけで、kさん「infoseek, tukaeru, prohosting」で調査お願いします<人任せ(笑)。

今回のサンプリング調査で、ECOUP有料サーバで使われている割合が非常に高いですね〜♪v1.11以降が対象で半分以上が有料サーバでした。そういうもん何でしょうね☆

記事情報
子タイトル
追伸:広告挿入有無での動作
投稿者情報
  • PONTA
  • Mail
  • HP
  • 2004年03月08日(月) 16時46分
投稿内容

無料xreaサーバですが、広告が非表示になるxフォルダ内では正常に動作しました。「http://wallshop.s2.xrea.com/ecoup/」「http://wallshop.s2.xrea.com/x/」共にLocation設定。

記事情報
子タイトル
Re: 追伸:広告挿入有無での動作
投稿者情報
  • k
  • .
  • .
  • 2004年03月09日(火) 13時46分
投稿内容

>kさん「infoseek, tukaeru, prohosting」で調査お願いします
「使える」以外はアカウント持っているのですが、プロホスはFTPが繋がらないまま放置状態だし、iswebも諸般の事情で放置したままですからねぇf^^
ちょっと時間が出来たときにでも確認してみます。

とはいえ今回の不具合修正でまずほとんどの環境で問題がなくなったのではないですか?

話しは変わりますが、今更ながら昨日ActivePerlとAnHTTPDを導入しました(汗
本格的のにPerlを勉強するには環境を整えないとダメですからねf^^
ついでにPerl用にエディタもez-HTMLというやつに変えました。
今までは秀丸でやっていたのですが、ez-HTMLにしてからはCGIのローカルプレビューもできるようになって大変重宝します♪
これから本格的にPerlを勉強しようとする人には大変お勧めですね。
もちろんそこまで勉強する気が無くてもいちいちサーバーにアップロードして確認するような他人迷惑なこともしないでローカルで手軽に動作チェックが出来るので導入をお勧めします。

記事情報
子タイトル
ローカルで無限ループは常です♪
投稿者情報
  • PONTA
  • Mail
  • HP
  • 2004年03月09日(火) 18時05分
投稿内容

やったー何気に言ったら調査してくれるって♪ECOUP2ばかり弄らないでECOUPも更新しなくちゃいけないなぁ。

ez-HTMLですか、私も使ってみようかなぁ〜。IEだけなら、楽に確認出来るね。ゴチャゴチャしたエディタは好かんから使えるかなぁ〜。下手した「IE6,OP6,OP7,NN4,NN7,MozillaFirebird,Lnyx」7つもブラウザ立ち上げてますね(汗)。使えたら乗り換え決定ですね。

記事情報
子タイトル
マジですか?( ̄□ ̄;)
投稿者情報
  • k
  • .
  • .
  • 2004年03月09日(火) 22時55分
投稿内容

>やったー何気に言ったら調査してくれるって♪
iswebはまぁ時間さえあれば可能なんですが、ProhostingはFTPがダメダメだからかなり厳しいかも…
Netfirmなら比較的簡単なんですがねぇf^^
いづれにせよしばらく時間は下さい。

追伸
ez-HTMLはデフォルトでIE、NN、Opera、Mozilla、FireBirdは対応しているのでよさげではないですか?恐らくデバッグが楽になると思いますf^^

記事情報
子タイトル
ECOUP(エコアップ)v1.14公開CHU♪
投稿者情報
  • PONTA
  • Mail
  • HP
  • 2004年03月09日(火) 23時49分
投稿内容

「v1.12→(v1.13)→v1.14」0.02も増えましたね。というわけで、サポート情報をフィードバックしました。これで、ある程度いけるんじゃないでしょうかねぇ♪菅原配布物が増えていたのでそれも包括しました。

>サーバ調査
何時でも良いですよ。お暇な時にでもお願いします。

>ez-HTML
かなり対応していますね。設定がもの凄く憂鬱になりました。アウトラインとツリー解析とサイズが、確認用にかなり使えそうな感じです。使えないのがタブメニューバー(笑)。使わなそうな物ばかりある(汗)。ここが自分で変更出来たら最高なんだけどなぁ〜。基本テンプレート,meta,link,rubyとフォーム系だけで十分だ(^-^;。CSSの連携があればかなり嬉しいなぁ<おぃ!

追伸:私が秀丸を使う理由・・・ダブルクリックで文字が最適に選択されるところ(^-^;)。実は、これだけで十分なのです〜♪

追伸:Perl文法チェック・・・最悪でした・・・。おかしいと思ってたら、やっぱり間違ってたのかぁ<分かってたら直せよぉ!

記事情報

親タイトル
[9] 画像挿入
投稿者情報
  • きり
  • .
  • .
  • 2004年03月09日(火) 21時33分
投稿内容

こんばんわ、初めまして。きりと申します。
さっそくですが、今HP作成をしているのですが画像挿入のやり方がわかりません(汗
ホームページビルダー8を使っているのですが
お絵描き掲示板で描いたイラストは普通に挿入できるのですが
ペインターとゆうお絵描きソフトで描いたイラストは何故だかページに挿入できません。
どうしてだか、全くわかりません;
よろしければ、画像挿入の仕方を教えて頂けないでしょうか・・?
宜しくお願い致します。
長文、失礼致しました。では。

記事情報
子タイトル
Re: 画像挿入
投稿者情報
  • k
  • .
  • .
  • 2004年03月09日(火) 22時39分
投稿内容

ビルダーはちょこっとしか使ったことないのでよく知りませんけど、基本的な操作ミスによる問題で挿入(src imgのタグ)できないのか、挿入したい画像に問題があって何らかのエラーが出るのか?質問内容が明確でないですから答えようにもわかりません…
せめてもう少し詳しく状況を書いてほしいです。

1)操作がわからない→まずは付属のヘルプファイルに目を通す
2)画像挿入操作をすると何らかのエラーが出る→どういったエラーなのか?

またビルダーには関係なく、挿入自体は出来ていて単に画像が表示されないだけであればHTMLタグの間違いかファイルパスが間違っているとか、画像ファイルに問題がある等いろいろ原因があります。
画像ファイルに問題があって表示されないとすれば…

・お絵描き掲示板で描いたイラスト
・ペインターとゆうお絵描きソフトで描いたイラスト

の画像フォーマットを確認することもしてみましょう。

記事情報
子タイトル
ペインタークラシック専用ファイルですかな?
投稿者情報
  • PONTA
  • Mail
  • HP
  • 2004年03月09日(火) 23時33分
投稿内容

きりさん、ども始めまして、管理人のPONTAです。

画像の挿入は「<img src="画像までのパス" width="横幅" height="高さ" alt="画像の説明">」というタグで可能です。ホームページビルダーでも、タグが編集出来ますので、手動で変更してみてはどうでしょうか?

お絵描き掲示板で描いたイラストは挿入出来るのであれば操作方法には問題がないかとおもいますので、画像形式が問題かもしれませんね。特に市販ソフトでは、独自形式で保存しているのでそれをインターネットで使用出来る画像に変更する必要があります。保存する時に画像形式を「jpg, gif, png」の何れかに変更して保存してみて下さい。ペインターだったらrifファイルかな?CG系の絵ならjpegファイルで保存したら良いですね。

と、情報不足から想定して質問に答えてみました。kさんが初歩的な所を突っ込んでいるので私は、やりがちなところを(謎)。

記事情報

親タイトル
[0] サイズは関係あるんですかねぇ?
投稿者情報
  • あい
  • Mail
  • HP
  • 2004年03月09日(火) 17時48分
投稿内容

あの。。。バナーようの88×31の画像でやってみると、作成できました。とは出るのですが、画像が出てこないんです…。前は、32×32の大きさのバナーで作成できたのですが、なぜでしょうか?メールでもいいので是非教えてください!お願いします!

記事情報
子タイトル
リファラで弾かれてるのかな?
投稿者情報
  • PONTA
  • Mail
  • HP
  • 2004年03月09日(火) 18時41分
投稿内容

一応通常テキストリンクも取り付けました。これでどうでしょうか?

また、画像への直接リンクの対策の副作用で、セキュリティソフトの影響をうけ画像が表示されないことも起こりえます。トップページのタイトル画像が表示されない場合は、セキュリティソフトをOFFなどにして対応して下さい。「セキュリティソフトのリファラー設定」を変更して下さい。[→設定方法例http://service1.symantec.com/SUPPORT/INTER/nisjapanesekb.nsf/jp_docid/20021020160209947]

記事情報

ページ移動