[MYBBS] 返信


メニュー


返信フォーム

[1] 入力フォーム
前書き
  • [名前][コメント][削除パス]は、必須項目です。
  • 他サイトの物は、そのサイトで質問して下さい。特に挨拶等のない場合は、当サイトにソース毎を持ち込まれても、削除対象とさせて頂きます。
  • サポート依頼時は、状況を出来る限り詳細に説明して下さい。
*必須*
  • 内容が推測出来る様なタイトルにして下さい。
*必須* [Max.5120 Byte]
  • 長文は、自動折り返しされるため、出来る限り改行はご遠慮下さい。
  • 二回以上の改行は、段落扱いになります。
  • [new] 内容の薄い書込や、機種依存文字の濫用は、削除対象となりました。
  • 使用可能タグ ⇒ strong, em, blockquote, cite, q, sup, sub, dfn, code, samp, var, kbd, pre
[C] カラー(未設定)

*必須*
  • ※投稿ルールを守られない記事は、削除対象になります。
  • 投稿内容は、即座にメールで管理人の元へ届きます。

特定スレッド内リンク


特定スレッド表示


親タイトル
[1] ecobbs.cgiを設置したいのですが旨く動きません。教えてください。
投稿者情報
  • 徳田真一
  • Mail
  • HP
  • 2005年02月06日(日) 03時36分
投稿内容

 おはようございます 徳田真一といいます
ffftpでレンタルサーバのecobbsのディレクトリを作り、ファイルをアップしましたが、CGIは実行できるのですが画像がアップできません。

 とりあえず、public_htmlの下にecobbsのディレクトリを作り、
 http://mds.nsf.tc/ecobbs/ecobbs.cgiを実行したところ旨く走ったので旨くはしるかな〜〜と
 思ったのですが、画像アップが出来ませんでした。
 管理者の設定画面の設定でしょうか。よくわかりません。
 どなたか、教えて頂けないでしょうか。何せ、CGIにはあまり詳しくないものですから。
 誠にすみませんが宜しくお願いします。
 
・このCGIは、/public_html/cgi-bin/ecobbs/のディレクトリしないと動かないのでしょうか。
 でもこうすると、このレンタルサーバは、CGIの実行が出来ません。

すみませんが宜しくお願いします。

 

記事情報
子タイトル
権限な問題かな?
投稿者情報
  • PONTA
  • Mail
  • HP
  • 2005年02月06日(日) 18時03分
投稿内容

徳田さん、こんばんは。管理人のPONTAです。

管理人専用になっているので、テストできませんでした。試してみないことには何にもわかりませんです。設置場所は、CGIが動作するディレクトリなら何処でも構いません。

過去にあった事例なのですが、複数FTPユーザーがいて、権限が異なる場合に不具合が生じることがあります。ご確認下さい。

記事情報
子タイトル
画像アップ可能?
投稿者情報
  • PONTA
  • Mail
  • HP
  • 2005年02月06日(日) 18時19分
投稿内容

試してみたところ画像がアップできたようですが。。。
どういった感じでアップできないのか詳しくお願いいたします。

記事情報
子タイトル
よくわかりませんが、1.33aで旨く画像アップできます
投稿者情報
  • 徳田真一
  • Mail
  • HP
  • 2005年02月07日(月) 19時19分
投稿内容

こんにちは
1.33aで旨く画像アップできます。
1.35と1.33aの違いでしょうか。どこが違うのですか。
画像アップ方法は、同じです。設定も同じようにしました。
私には、わかりません。
でも、この画像アップボード気に入っているので1.33aで使わせて頂きます。
初心者な物ですから、間違いがあるかもしれません。
また、何かありましたら掲示板にアップします。
徳田真一

開発者様、管理人様ありがとうございました。
がりんこサーチにはバナーを張っています。
HPのアドレスは
http://mds.nsf.tc/index.html
です。

記事情報
子タイトル
Re: よくわかりませんが、1.33aで旨く画像アップできます
投稿者情報
  • PONTA
  • Mail
  • HP
  • 2005年02月09日(水) 23時31分
投稿内容

気に入って頂けてるようで嬉しい限りです(^-^;)

別に大差はなかったと思いますが。。。どんな画像でもアップ出来ないのでしょうか?それとも特定の画像だけで生じるのでしょうか?そうならば、一度その画像を送ってみて下さい。こちらでも、試してみます。

記事情報
子タイトル
ISDN回線について
投稿者情報
  • 徳田真一
  • Mail
  • HP
  • 2005年02月11日(金) 07時15分
投稿内容

開発者様へ

 ISDN回線を使ってCGIのファイルを転送してパーミッションの設定及びその後の画像の転送をしていました。私の家は、ADSLなどの高速回線を使えない地域ですのでこれしかありません。
 この環境では、ecobbsのCGIは走るのですが、画像転送ができませんでした。
ちなみに職場はADSLなので同じことを試しにやってみました。そうしたら旨くいきました。
ちなみに、ADSL回線で設定した時、自宅のISDN回線を使って一度だけは、画像の転送ができました。
 その後は、できなくなりました。
(CGIはきちんと走ります。画像アップだけできませんでした。)
一回した試していませんが。そのときは、明日職場から設定しなをそうと思いました。ちゃんとできました。設定も画像アップもOKです。その後画像アップは職場からするようにしています。全然問題ありません。

多分回線の種類のせいではないでしょうか。(回線の種類の設定はありませんよね。)
 1.33aや1.35のバージョンの違いではないです。
ADSLでの設定、画像アップをした時に1.35じゃなくって試しに1.33aを使ったのでバージョンのちがいかな〜〜て思いました。TCP/IPを使っている以上転送方法は同じだと思いますがよく解りません。
(詳しく調べていません。CGIが走り、画像アップで目的を果たしましたので!!)
とりあえず、調べてみる価値はあると思います。(記事一覧も詳しく見ていません。)
 ですから、どこかにのっているのかな??
もし違っていたら、ごめんなさい。
(自宅の環境は、ネットワーク環境が、FreeBSDのサーバ一台、クライアント3台です。でもほかのCGI画像アップは旨くいってますからね。)
 
 以 上

記事情報
子タイトル
サーバのタイムアウトが問題では?
投稿者情報
  • PONTA
  • Mail
  • HP
  • 2005年02月13日(日) 15時16分
投稿内容

徳田さん、こんにちは。ISDN回線では、サーバのタイムアウトが原因に考えられますね。通信状況などが影響して、設定時間内にアップロードが完了したり、未完了だったりしますので、成功・失敗に直結します。サーバ及びブラウザのタイムアウト時間を長めに設定すれば解決すると思いますが。。。画像ダイエット機能などの趣味趣向の処理があるので、若干他社のCGIよりかは時間が掛かりますからね(苦笑)。それの要因の一つになってるのかもしれませんね(^-^;)

ISDN回線で、一度小さな画像アップで試してみて下さいな。ではではまたです。

記事情報